Published on 2024-09-12 01:13 by Niladri Das
Introduction to Default Routing
Default routing is a technique used to forward packets to a default gateway when the destination network is not present in the routing table. It is used to provide a fallback route when no other route is available.
Theory
Default routing uses the following key concepts:
- Default gateway: The default gateway is the router that packets are sent to when the destination network is not present in the routing table.
- Static routes: Static routes are used to configure default routing in routers.
Summary
Default routing is a simple technique used to provide a fallback route when no other route is available. It is commonly used in networks where there is a single exit point to the internet.
Configuration and Verification
R1 (Default Route)
R1 Configuration
Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface fa0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial0/0/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#clock rate 64000
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.12.2
R1(config)#exit
R1 Verification
R1#show running-config
R1#show ip route
R1#write
R2 (Static Route)
R2 Configuration
Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface fa0/0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial0/0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial 0/0/1
R2(config-if)#ip address 192.168.23.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#clock rate 64000
R2(config-if)#exit
R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.12.1
R2(config)#ip route 192.168.3.0 255.255.255.0 192.168.23.2
R2 Verification
R2#show running-config
R2#show ip route
R2#write
R3 (Default Route)
R3 Configuration
Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#interface fa0/0
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface serial0/0/0
R3(config-if)#ip address 192.168.23.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#ip route 0.0.0.0 0.0.0.0 192.168.23.1
R3 Verification
R3#show running-config
R3#show ip route
R3#write
Written by Niladri Das
← Back to blog